Copyrights

© Cypress Semiconductor Corporation, 2017. This document is the property of Cypress Semiconductor Corporation and its subsidiaries, including Spansion LLC ("Cypress"). This document, including any software or firmware included or referenced in this document ("Software"), is owned by Cypress under the intellectual property laws and treaties of the United States and other countries worldwide. Cypress reserves all rights under such laws and treaties and does not, except as specifically stated in this paragraph, grant any license under its patents, copyrights, trademarks, or other intellectual property rights. If the Software is not accompanied by a license agreement and you do not otherwise have a written agreement with Cypress governing the use of the Software, then Cypress hereby grants you a personal, non-exclusive, nontransferable license (without the right to sublicense) (1) under its copyright rights in the Software (a) for Software provided in source code form, to modify and reproduce the Software solely for use with Cypress hardware products, only internally within your organization, and (b) to distribute the Software in binary code form externally to end users (either directly or indirectly through resellers and distributors), solely for use on Cypress hardware product units, and (2) under those claims of Cypress’s patents that are infringed by the Software (as provided by Cypress, unmodified) to make, use, distribute, and import the Software solely for use with Cypress hardware products. Any other use, reproduction, modification, translation, or compilation of the Software is prohibited.

TO THE EXTENT PERMITTED BY APPLICABLE LAW, CYPRESS MAKES NO WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, WITH REGARD TO THIS DOCUMENT OR ANY SOFTWARE OR ACCOMPANYING HARDWARE, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. To the extent permitted by applicable law, Cypress reserves the right to make changes to this document without further notice. Cypress does not assume any liability arising out of the application or use of any product or circuit described in this document. Any information provided in this document, including any sample design information or programming code, is provided only for reference purposes. It is the responsibility of the user of this document to properly design, program, and test the functionality and safety of any application made of this information and any resulting product. Cypress products are not designed, intended, or authorized for use as critical components in systems designed or intended for the operation of weapons, weapons systems, nuclear installations, life-support devices or systems, other medical devices or systems (including resuscitation equipment and surgical implants), pollution control or hazardous substances management, or other uses where the failure of the device or system could cause personal injury, death, or property damage ("Unintended Uses"). A critical component is any component of a device or system whose failure to perform can be reasonably expected to cause the failure of the device or system, or to affect its safety or effectiveness. Cypress is not liable, in whole or in part, and you shall and hereby do release Cypress from any claim, damage, or other liability arising from or related to all Unintended Uses of Cypress products. You shall indemnify and hold Cypress harmless from and against all claims, costs, damages, and other liabilities, including claims for personal injury or death, arising from or related to any Unintended Uses of Cypress products.

Cypress, the Cypress logo, Spanision, the Spanision logo, and combinations thereof, PSoC, CapSense, EZ-USB, F-RAM, and Traveo are trademarks or registered trademarks of Cypress in the United States and other countries. For a more complete list of Cypress trademarks, visit cypress.com. Other names and brands may be claimed as property of their respective owners.
# Contents

Safety Information ............................................. 5

1. Introduction ................................................. 7
   1.1 Kit Contents .................................................. 7
   1.2 PSoC Creator ................................................. 8
      1.2.1 PSoC Creator Code Examples ..................... 9
      1.2.2 Kit Code Examples ................................... 10
      1.2.3 PSoC Creator Help ................................... 10
      1.2.4 Component Datasheets ............................. 11
   1.3 Getting Started ........................................... 11
   1.4 Additional Learning Resources ....................... 12
   1.5 Technical Support ......................................... 12
   1.6 Document Conventions ................................. 13
   1.7 Acronyms ................................................... 14

2. Software Installation ....................................... 15
   2.1 Before You Begin .......................................... 15
   2.2 Install Software ........................................... 15
   2.3 Uninstall Software ........................................ 17

3. Kit Operation ............................................... 18
   3.1 Theory of Operation ..................................... 18
   3.2 Programming and Debugging the PSoC 4200DS Target Device ...................... 20
      3.2.1 Programming Using PSoC Creator .................. 20
      3.2.2 Debugging Using PSoC Creator .................... 22
      3.2.3 Programming Using PSoC Programmer ............ 22
      3.2.4 Mass Storage Programming ......................... 22
   3.3 USB-UART Bridge ........................................ 22
   3.4 USB-I2C Bridge ............................................ 23
   3.5 Updating the KitProg2 Firmware ...................... 23

4. Code Examples ............................................. 24
   4.1 Using the Kit Code Examples ........................... 24
   4.2 Using Built-in PSoC Creator Code Examples with the Kit .......................... 28
Contents

Appendix 31

Board Details .................................................................................................................31
Hardware Details .............................................................................................................32
    Target Board .........................................................................................................32
    KitProg2 Board .................................................................................................33
Power Supply System ........................................................................................................34
Board Separation (Snapping) ........................................................................................34
Header Connections ......................................................................................................35
User and Passive Inputs ...............................................................................................38

PSoC 4200DS Prototyping kit Schematics .........................................................................41
Bill of Materials ............................................................................................................41
Programming PSoC 4200DS Prototyping kit Using MiniProg3/KitProg2 .........................42

Revision History 43
Safety Information

Regulatory Compliance

The CY8CKIT-146 PSoC 4200DS Prototyping Kit is intended for use as a development platform for hardware or software in a laboratory environment. The board is an open system design, which does not include a shielded enclosure. This may cause interference to other electrical or electronic devices in close proximity. In a domestic environment, this product may cause radio interference. In such cases, you may be required to take adequate preventive measures. In addition, this board should not be used near any medical equipment or RF devices.

Attaching additional wiring to this product or modifying the product operation from the factory default settings may affect its performance and cause interference with other apparatus in the immediate vicinity. If such interference is detected, suitable mitigating measures should be taken.

The PSoC 4200DS Prototyping Kit, as shipped from the factory, has been verified to meet with requirements of CE as a Class A product.

The PSoC 4200DS Prototyping Kit contains electrostatic discharge (ESD) sensitive devices. Electrostatic charges readily accumulate on the human body and any equipment, and can discharge without detection. Permanent damage may occur on devices subjected to high-energy discharges. Proper ESD precautions are recommended to avoid performance degradation or loss of functionality. Store unused PSoC 4200DS Prototyping Kit boards in the protective shipping package.

End-of-Life/Product Recycling

This kit has an end-of life five years from the date of manufacture mentioned on the back of the box. Contact your nearest recycler for discarding the kit.
General Safety Instructions

ESD Protection

ESD can damage boards and associated components. Cypress recommends that you perform procedures only at an ESD workstation. If such a workstation is not available, use appropriate ESD protection by wearing an antistatic wrist strap attached to the chassis ground (any unpainted metal surface) on your board when handling parts.

Handling Boards

PSoC 4200DS Prototyping boards are sensitive to ESD. Hold the board only by its edges. After removing the board from its box, place it on a grounded, static-free surface. Use a conductive foam pad if available. Do not slide board over any surface.
1. Introduction

Thank you for your interest in the CY8CKIT-146 PSoC 4200DS Prototyping Kit. The PSoC 4200DS prototyping kit is designed as an easy-to-use and inexpensive prototyping platform. The PSoC 4200DS Prototyping Kit supports the PSoC 4200DS device family, delivering a complete system solution for a wide range of embedded applications at a very low cost. The PSoC 4200DS device is a true programmable embedded system-on-chip, integrating custom digital peripheral functions, memory, and an ARM® Cortex®-M0 microcontroller on a single chip. The programmable digital peripheral functions allow higher flexibility, in-field tuning of the design, and faster time-to-market.

The PSoC 4200DS Prototyping Kit offers an open footprint breakout board to maximize the end-utility of the PSoC 4200DS device. This kit provides a low-cost alternative to device samples while providing a platform to easily develop and integrate the PSoC 4200DS device into your end-system. In addition, the board includes the following features:

- An LED to provide feedback
- A push button to provide a simple user input
- 5V operation

The PSoC 4200DS prototyping kit also integrates the Cypress KitProg2 that enables on-board programming, debugging and bridging functionality, such as USB-UART and USB-I2C. The KitProg2 is used to program and debug the target PSoC 4200DS device (see Figure 1-1). The prototyping kit allows you to separate the KitProg2 board from the PSoC 4200DS target board.

1.1 Kit Contents

The PSoC 4200DS Prototyping Kit contains a PSoC 4200DS Prototyping board and Quick Start Guide.

Figure 1-1. CY8CKIT-146 PSoC 4200DS Prototyping Kit
1.2 PSoC Creator

PSoC Creator™ is a state-of-the-art, easy-to-use integrated design environment (IDE). It introduces revolutionary hardware and software co-design, powered by a library of pre-verified and pre-characterized PSoC Components. With PSoC Creator, you can:
1. Drag and drop Components to build your hardware system design in the main design workspace
2. Codesign your application firmware with the PSoC hardware
3. Configure Components using configuration tools
4. Explore the library of 100+ Components
5. Review Component datasheets

Figure 1-2. PSoC Creator Features

PSoC Creator also enables you to tap into an entire tool ecosystem with integrated compiler chains and production programming programmers for PSoC devices.

For more information, visit www.cypress.com/psoccreator. Visit the PSoC Creator Video Training Page for video tutorials on learning and using PSoC Creator.
1.2.1 PSoC Creator Code Examples

PSoC Creator includes a large number of code examples. These examples are available from the PSoC Creator Start Page, as Figure 1-3 on page 9 shows or from the menu under "File > Code Example...".

Code examples can speed up your design process by starting you off with a complete design, instead of a blank page. The code examples also show how PSoC Creator Components can be used for various applications. Code examples and documentation are included, as shown in Figure 1-4 on page 10.

In the Find Example Project dialog shown in Figure 1-4, you have several options:

- Filter for examples based on architecture or device family, that is, PSoC 3, PSoC 4, or PSoC 5LP; project name; or keyword
- Select from the list of examples offered based on the Filter Options
- Review the example project’s description (on the Documentation tab)
- Review the code from the Sample Code tab. You can copy the code from this window and paste to your project, which can help speed up code development
- Create a new project (and a new workspace if needed) based on the selection. This can speed up your design process by starting you off with a complete, basic design. You can then adapt that design to your application.

Figure 1-3. Code Examples in PSoC Creator
1.2.2 Kit Code Examples

You can access the installed kit code examples from the PSoC Creator Start Page. To access these examples, expand the Kits; then, expand the specific kit to see the code examples. Refer to the Code Examples chapter on page 24 for a list of code examples that you can use on this kit.

1.2.3 PSoC Creator Help

Launch PSoC Creator and navigate to the following items:

- **Quick Start Guide**: Choose Help > Documentation > Quick Start Guide. This guide gives you the basics for developing PSoC Creator projects.

- **Simple Component Code Examples**: Choose File > Code Example. These examples demonstrate how to configure and use PSoC Creator Components. To access examples related to a specific Component, right-click on the Component in the schematic or in the Component Catalog. Select the Find Code Example option in the context menu that appears.

- **System Reference Guide**: Choose Help > System Reference Guides. This guide lists and describes the system functions provided by PSoC Creator.
1.2.4 Component Datasheets

Right-click a Component and select **Open Datasheet** (see Figure 1-5 on page 11).

Figure 1-5. Opening Component Datasheet

1.3 Getting Started

This guide will help you get acquainted with the PSoC 4200DS Prototyping Kit:

- The **Software Installation chapter on page 15** describes the installation of the kit software. This includes installation of the PSoC Creator IDE for development and debugging the applications, and PSoC Programmer for programming hex files.
- The **Kit Operation chapter on page 18** describes the major features of the PSoC 4200DS Prototyping Kit and functionalities such as programming, debugging, and the USB-UART and USB-I2C bridges.
- The **Hardware chapter on page 23** details the hardware content of the kit and the hardware operation.
- The **Code Examples chapter on page 24** describes multiple code examples that will help you understand how to create your own PSoC 4200DS projects.
- The **Appendix chapter on page 31** provides schematics, details about programming the kit using Miniprog, Kit Schematics, and the bill of materials (BOM).
1.4 Additional Learning Resources

Cypress provides a wealth of data at www.cypress.com to help you to select the right PSoC device for your design, and to help you to quickly and effectively integrate the device into your design. For a comprehensive list of resources, see KBA86521, How to Design with PSoC 3, PSoC 4, and PSoC 5LP. The following is an abbreviated list for PSoC 4:

- **Overview:** PSoC Portfolio and PSoC Roadmap.
- **Product Selectors:** PSoC 4 Product Selector. In addition, PSoC Creator includes a device selection tool.
- **Datasheets:** Describe and provide electrical specifications for the PSoC 4000, PSoC 4100, PSoC 4200, PSoC 4100M, PSoC 4200M, PSoC 4200L and PSoC 4000S device families.
- **CapSense Design Guide:** Learn how to design capacitive touch-sensing applications with the PSoC 4 family of devices.
- **Application Notes and Code Examples:** Cover a broad range of topics, from basic to advanced. Many of the application notes include code examples. Visit the PSoC 3/4/5 Code Examples web page for a list of all available PSoC Creator code examples. To access code examples from within PSoC Creator - see PSoC Creator Code Examples on page 10.
- **Technical Reference Manuals (TRM):** Provide detailed descriptions of the architecture and registers in each PSoC 4 device family.
- **Development Kits:**
  - CY8CKIT-041, CY8CKIT-046, CY8CKIT-044, CY8CKIT-042, and CY8CKIT-040 are easy-to-use and inexpensive development platforms. These kits include connectors for Arduino™ compatible shields and Digilent Pmod Peripheral Modules.
  - CY8CKIT-043, CY8CKIT-049, CY8CKIT-145, and CY8CKIT-146 are very low-cost prototyping platforms for sampling PSoC 4 devices.
  - CY8CKIT-001 is a common development platform for all PSoC family devices.
  - The MiniProg3 device provides an interface for flash programming and debug.
- **Knowledge Base Articles (KBA):** Provide design and application tips from experts on using the device.
- **PSoC Creator Training:** Visit www.cypress.com/go/creatorstart/creatortraining for a comprehensive list of video training on PSoC Creator.
- **Learning from Peers:** Visit www.cypress.com/forums to meet enthusiastic PSoC developers discussing the next-generation embedded systems on Cypress Developer Community Forums.

1.5 Technical Support

For assistance, visit Cypress Support or contact customer support at +1(800) 541-4736 Ext. 2 (in the USA) or +1 (408) 943-2600 Ext. 2 (International).

You can also use the following support resources if you need quick assistance:

- **Self-help (Technical Documents)**
- **Local Sales Office Locations**
## Document Conventions

Table 1-1. Document Conventions for Guides

<table>
<thead>
<tr>
<th>Convention</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>Courier New</td>
<td>Displays file locations, user entered text, and source code: \ <code>C:\...cd\icc\</code></td>
</tr>
<tr>
<td><em>Italics</em></td>
<td>Displays file names and reference documentation: Read about the <em>sourcefile.hex</em> file in the <em>PSoC Creator User Guide</em>.</td>
</tr>
<tr>
<td>[Bracketed, Bold]</td>
<td>Displays keyboard commands in procedures: [Enter] or [Ctrl] [C]</td>
</tr>
<tr>
<td>File &gt; Open</td>
<td>Represents menu paths: File &gt; Open &gt; New Project</td>
</tr>
<tr>
<td><strong>Bold</strong></td>
<td>Displays commands, menu paths, and icon names in procedures: Click the <em>File</em> icon and then click <em>Open</em>.</td>
</tr>
<tr>
<td>Times New Roman</td>
<td>Displays an equation: 2 + 2 = 4</td>
</tr>
<tr>
<td>Text in gray boxes</td>
<td>Describes Cautions or unique functionality of the product.</td>
</tr>
</tbody>
</table>
### 1.7 Acronyms

Table 1-2. Acronyms Used in this Document

<table>
<thead>
<tr>
<th>Acronym</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ADC</td>
<td>Analog-to-Digital Converter</td>
</tr>
<tr>
<td>BLE</td>
<td>Bluetooth Low Energy</td>
</tr>
<tr>
<td>BOM</td>
<td>Bill of Materials</td>
</tr>
<tr>
<td>CMOD</td>
<td>Modulator Capacitor</td>
</tr>
<tr>
<td>CMP</td>
<td>Comparator</td>
</tr>
<tr>
<td>CTANK</td>
<td>Shield tank capacitor</td>
</tr>
<tr>
<td>DAC</td>
<td>Digital to Analog Convertor</td>
</tr>
<tr>
<td>DPDT</td>
<td>Double-Pole, Double-Throw</td>
</tr>
<tr>
<td>ESD</td>
<td>Electrostatic Discharge</td>
</tr>
<tr>
<td>GPIO</td>
<td>General Purpose Input/Output</td>
</tr>
<tr>
<td>I2C</td>
<td>Inter-Integrated Circuit</td>
</tr>
<tr>
<td>IDAC</td>
<td>Current DAC</td>
</tr>
<tr>
<td>IDE</td>
<td>Integrated Development Environment</td>
</tr>
<tr>
<td>LED</td>
<td>Light-Emitting Diode</td>
</tr>
<tr>
<td>PRoC</td>
<td>Programmable Radio-on-Chip</td>
</tr>
<tr>
<td>PSoC</td>
<td>Programmable Systems-on-Chip</td>
</tr>
<tr>
<td>SAR</td>
<td>Successive Approximation Register</td>
</tr>
<tr>
<td>SCB</td>
<td>Serial Communication Block</td>
</tr>
<tr>
<td>SRAM</td>
<td>Static Random Access Memory</td>
</tr>
<tr>
<td>SWD</td>
<td>Serial Wire Debug</td>
</tr>
<tr>
<td>TCPWM</td>
<td>Timer, Counter, Pulse Width Modulator</td>
</tr>
<tr>
<td>UART</td>
<td>Universal Asynchronous Receiver Transmitter</td>
</tr>
<tr>
<td>USB</td>
<td>Universal Serial Bus</td>
</tr>
<tr>
<td>WCO</td>
<td>Watch Crystal Oscillator</td>
</tr>
</tbody>
</table>
2. Software Installation

This chapter describes the steps to install the software tools and packages on a PC for using the PSoC 4200DS Prototyping Kit. This includes the IDE on which the projects will be built and used for programming.

2.1 Before You Begin

All Cypress software installations require administrator privileges, but these are not required to run the software after it is installed. Close any other Cypress software that is currently running before installing the kit software.

2.2 Install Software

Follow these steps to install the PSoC 4200DS Prototyping kit software:

1. Download the PSoC 4200DS Prototyping kit software from http://www.cypress.com/CY8CKIT-146. The kit software is available in three formats for download.
   a. CY8CKIT-146 Kit Only: This executable file installs only the kit contents, which include kit code examples, hardware files, and user documents. This package can be used if all the software prerequisites (listed in step 5) are installed on your PC.
   b. CY8CKIT-146 Kit Setup: This installation package contains the files related to the kit including PSoC Creator and PSoC Programmer. However, it does not include the Windows Installer or Microsoft .NET framework packages. If these packages are not on your computer, the installer directs you to download and install them from the Internet.
   c. CY8CKIT-146 DVD ISO: This file is a complete package, stored in a DVD-ROM image format, that you can use to create a DVD or extract using an ISO extraction program such as WinZip or WinRAR. The file can also be mounted like a virtual CD/DVD using virtual drive programs such as Virtual CloneDrive and MagicISO. This file includes all the required software, utilities, drivers, hardware files, and user documents.

2. If you have downloaded the ISO file, mount it in a virtual drive. Extract the ISO contents if you do not have a virtual drive to mount. Double-click cyaautorun.exe in the root directory of the extracted content or mounted ISO if “Autorun from CD/DVD” is not enabled on the PC. The installation window will appear automatically.
   Note: If you are using the “Kit Setup” or “Kit Only” file, then go to step 4 for installation.
3. **Click Install CY8CKIT-146 Kit** to start the kit installation, as shown in Figure 2-1.

![Kit Installer Screen](image)

Figure 2-1. Kit Installer Screen

4. Select the directory in which you want to install the PSoC 4200DS Prototyping kit-related files. Choose the directory and click **Next**.

5. When you click **Next**, the PSoC 4200DS Prototyping kit installer automatically installs the required software, if it is not present on your computer. The following is the required software:
   a. PSoC Creator 4.1 or later: This software is also available separate from the kit at [www.cypress.com/psoccreator](http://www.cypress.com/psoccreator).
   b. PSoC Programmer 3.26 or later: This is installed as part of PSoC Creator installation ([www.cypress.com/programmer](http://www.cypress.com/programmer)).
6. Choose the **Typical/Custom/Complete** installation type in the Product Installation Overview window, as shown in Figure 2-2. Click **Next** after you select the installation type.

**Figure 2-2. Product Installation Overview**

7. Read the License agreement and select 'I accept the terms in the license agreement' to continue with installation. Click on **Next**.

8. When the installation begins, a list of packages appears on the installation page. A green check mark appears next to each package after successful installation.

9. Enter your contact information or select the check box **Continue Without Contact Information**. Click **Finish** to complete the PSoC 4200DS Prototyping kit installation.

10. After the installation is complete, the kit contents are available at the following location:

    `<Install_Directory>\CY8CKIT-146 PSoC 4200DS Prototyping Kit`

    **Default location:**

    - Windows OS (64-bit):
      
      `C:\Program Files (x86)\Cypress\CY8CKIT-146 PSoC 4200DS Prototyping Kit`

    - Windows OS (32-bit):
      
      `C:\Program Files\Cypress\CY8CKIT-146 PSoC 4200DS Prototyping Kit`

    **Note:** For Windows 7/8/8.1 users, the installed files and the folder are read-only. To use the installer code examples, follow the steps outlined in the Code Examples on page 24 chapter.

### 2.3 Uninstall Software

The software can be uninstalled using one of the following methods:

1. Go to **Start > All Programs > Cypress > Cypress Update Manager** and select the Uninstall button.

2. Go to **Start > Control Panel > Programs and Features for Windows 7** or **Add/Remove Programs for Windows XP**, select the Uninstall/Change button.
3. Kit Operation

This chapter introduces you to the different features of the PSoC 4200DS Prototyping kit. This primarily includes the programming/debugging functionality, KitProg2 USB-UART and USB-I2C bridges, and the method to update the KitProg2 firmware.

3.1 Theory of Operation

Figure 3-1 shows the block diagram for the PSoC 4200DS Prototyping kit.

The PSoC 4200DS Prototyping kit is simplistic in design and focuses on providing you with complete access to develop applications using the PSoC 4200DS device family. This kit supports the following features:

- **PSoC 4200DS I/O Headers**: The PSoC 4200DS Prototyping board brings all GPIOs of the target PSoC 4200DS device to the two expansion headers, enabling the user to have maximum access to the capabilities of the PSoC 4200DS device.

- **User LED**: The on-board LED can be used to display outputs from the PSoC 4200DS device. This includes modulating the brightness of the LED to notify different states of the device.

- **User Button**: This kit has a push button, which can be used to provide an input to the PSoC 4200DS.

  **Note**: The switch connects the PSoC 4200DS pin to ground when pressed. Therefore, you need to configure the PSoC 4200DS pin as 'resistive pull-up' for detecting the switch press.
Kit Operation

- **Reset Button:** This button is used to reset the PSoC 4200DS device when pressed.
- **Power LED:** The Amber Power LED turns ON when the kit is powered from USB finger connector.
- **PSoC 4200DS Device:** This is the target device on the board.
- **10-pin Programming Header:** This header allows you to program/debug the PSoC 4200DS using an external programmer such as MiniProg3. This header is not populated by default.
- **5-pin Programming Header:** These programming headers allow you to program/debug the PSoC 4200DS using external programmers such as MiniProg3 or KitProg2. After the board is snapped, J5 can be used to program/debug the PSoC 4200DS using external programmers. J4 can be used to program any other PSoC devices using the onboard PSoC 5LP (KitProg2).
- **PSoC 5LP IO Headers:** These headers bring out a few GPIO lines of the onboard PSoC 5LP device. These include the KitProg2 USB-I2C bridge lines and USB-UART bridge lines. The additional PSoC 5LP pins are direct connections to the internal programmable analog logic of PSoC 5LP. You can use these pins as General-purpose input/output (GPIO) also.
- **Current Measurement Jumper:** Using this jumper, you can measure the current consumed by the PSoC 4200DS device. This jumper is not populated by default.
- **USB Finger Connector:** A PCB USB connector is provided to connect the kit to a computer.
- **KitProg2:** The CY8C5868LTI-LP039 PSoC 5LP device (U1) serving as KitProg2 is a multi-functional system, which includes a programmer, debugger, USB-I2C bridge, and a USB-UART bridge. Refer to the [KitProg2 User Guide](#) for more details.
- **KitProg2 Mode Selection Button (SW3):** This button is used to switch between the KitProg2 modes. You can also use this button to provide an input to the PSoC 5LP in custom applications. Note that the switch connects the PSoC 5LP pin to ground when pressed. Table 3-1 gives a brief description of different LED status for various modes. Refer to the [KitProg2 User Guide](#) for more details.
- **KitProg2 Status LED:** The Amber Status LED indicates the status of KitProg2. Refer to the [KitProg2 User Guide](#) for more details.

### Table 3-1. Status LED behavior for various KitProg2 modes

<table>
<thead>
<tr>
<th>KitProg2 Programming Modes</th>
<th>Status LED (LED3)</th>
</tr>
</thead>
<tbody>
<tr>
<td>KitProg2 program/Debug Mode (PPCOM mode) (default)</td>
<td>ON</td>
</tr>
<tr>
<td>CMIS-DAP &amp; Mass Storage Programming Mode</td>
<td>Breathing</td>
</tr>
<tr>
<td>Bootloader Mode</td>
<td>Blinking</td>
</tr>
</tbody>
</table>
3.2 Programming and Debugging the PSoC 4200DS Target Device

The target PSoC 4200DS device can be programmed and debugged using the KitProg2. Before programming the device, ensure that PSoC Creator and PSoC Programmer software are installed on the PC. See Install Software on page 15 for more information.

3.2.1 Programming Using PSoC Creator

1. Connect the prototyping board to the computer through the PCB USB connector (J8), as shown in Figure 3-2. The kit enumerates as a composite device. If you are plugging in the PSoC 4200DS Prototyping Kit to your PC for the first time, the kit drivers will get installed automatically. Successful enumeration is indicated by Amber Status LED (LED3) ON. If the Amber Status LED (LED3) is not ON, refer to the KitProg2 User Guide for details on the KitProg2 status and troubleshooting instructions.

Figure 3-2. Connecting the PSoC 4200DS Prototyping Kit to a Computer

2. Open the desired project in PSoC Creator. From inside PSoC Creator, go to File > Open > Project/Workspace. This provides the option to browse to and open a previously saved project. If you want to open one of the example projects provided with the kit, follow the instructions in the Code Examples chapter.
3. Select the option **Build > Build <Project_Name>** or press [Shift] [F6] to build the project as shown in **Figure 3-3**.

**Figure 3-3. Build an Example Project**

4. If there are no errors during build, program the firmware into the kit by choosing **Debug > Program** or press [Ctrl] [F5], as shown in **Figure 3-4**. This programs the target PSoC 4200DS device on the PSoC 4200DS Prototyping kit, and the kit is ready to use.

**Figure 3-4. Programming Device From PSoC Creator**
3.2.2 Debugging Using PSoC Creator

For debugging the project using PSoC Creator, follow steps 1–3 from Programming Using PSoC Creator on page 20 followed by:

1. Click on the **Debug** icon  or press [F5]. Alternatively, you can use the option **Debug > Debug**.
2. Once the PSoC Creator opens in Debug mode, use the buttons on the toolbar to debug your application.

For more details on using the debug features, refer to section 3.2 of the KitProg2 User Guide.

3.2.3 Programming Using PSoC Programmer

PSoC Programmer (3.26.0 or later) can be used to program existing `.hex` files into the PSoC 4200DS Prototyping kit. Refer to the Programming Using PSoC Programmer section in the KitProg2 User Guide for a detailed explanation on how to program using PSoC Programmer.

3.2.4 Mass Storage Programming

The KitProg2 in PSoC 4200DS Prototyping board supports programming through a USB Mass Storage interface. This interface allows you to program the PSoC 4200DS devices by copying `.hex` files into an emulated USB Mass Storage device. For more details on KitProg2 Mass Storage Programmer, refer to the KitProg2 User Guide.

3.3 USB-UART Bridge

The KitProg2 on the PSoC 4200DS Prototyping Kit can act as a USB-UART bridge. The UART lines between the KitProg2 and the target are hard-wired on the board, through the snappable area, with UART_RX assigned to P1[0] and UART_TX assigned to P1[1] on PSoC 4200DS (target). For more details on the KitProg2 USB-UART functionality, refer to Using the KitProg2 USB-UART Bridge in KitProg2 User Guide.

Figure 3-5. UART Connection between KitProg2 and PSoC 4200DS
Kit Operation

3.4 USB-I2C Bridge

The KitProg2 can function as a USB-I2C bridge and communicate with the software utility, Bridge Control Panel (BCP). The I2C lines on PSoC 4200DS (target) device are P3[1] (SDA) and P3[0] (SCL), which are hardwired on the board to the I2C lines of the KitProg2. The USB-I2C supports I2C speeds of 50 kHz, 100 kHz, 400 kHz, and 1 MHz. For more details on the KitProg2 USB-I2C functionality, refer to Using the KitProg2 USB-I2C Bridge in KitProg2 User Guide.

Figure 3-6. I2C Connection between KitProg2 and PSoC 4200DS

3.5 Updating the KitProg2 Firmware

The KitProg2 firmware normally does not require any update. You can use the PSoC Programmer software to update the KitProg2 firmware if necessary. Refer to Updating the KitProg2 Firmware in KitProg2 User Guide for a detailed explanation on how to update the KitProg2 firmware.

4. Code Examples

This chapter explains the code examples provided along with the PSoC 4200DS Prototyping kit. To access these code examples, download and install the CY8CKIT-146 PSoC 4200DS Prototyping kit setup file from the kit web page: www.cypress.com/CY8CKIT-146. After installation, the code example can be accessed from the PSoC Creator Start page as shown in Figure 4-1.

4.1 Using the Kit Code Examples

Follow these steps to open and use the example projects.

1. Launch PSoC Creator from the Windows Start menu (Start > All Programs > Cypress > PSoC Creator <version> > PSoC Creator <version>).
2. On the Start page, click on CY8CKIT-146 under Examples and Kits > Kits. A list of example projects appears, as shown in Figure 4-1.
3. Click on the desired example project and save it at a desired location. For the remaining steps, CE97634_PSoC_4_Breathing_LED.cywrk is used as reference.

Figure 4-1. Open Example Project from PSoC Creator
4. Build the example project by choosing **Build > Build <Project Name>**, as shown in Figure 4-2. A .hex file is generated after a successful build process.

![Figure 4-2. Build Example Project from PSoC Creator](image)

5. Connect the PSoC 4200DS Prototyping kit to the PC using the KitProg2 PCB USB port, J8 as described in *Programming Using PSoC Creator chapter on page 20* to program the kit with this code example. If this is the first time the kit is connected to the PC, you should wait for driver installation to complete before proceeding with the next step.

6. Choose **Debug > Program** in PSoC Creator as shown in Figure 4-3.

![Figure 4-3. Program Device in PSoC Creator](image)
7. If the device is already acquired, programming will complete automatically and the result will appear in the PSoC Creator status bar at the bottom left side of the screen. If the device is yet to be acquired, the Select Debug Target window will appear. Select KitProg2/<serial number> and click the **Port Acquire** button, as shown in Figure 4-4.

Figure 4-4. Port Acquire

8. After the device is acquired, it is shown in a tree structure below the KitProg2/<serial number>. Click the **Connect** button and then click **OK** to exit the window and start programming, as shown in Figure 4-5.

Figure 4-5. Connect Device From PSoC Creator and Program
9. From the workspace explorer in PSoC Creator, open the *CE97634 PSoC 4200DS Breathing LED.pdf* as shown in Figure 4-6.

Figure 4-6. Project Document - CE97634 PSoC 4 Breathing LED.pdf
4.2 Using Built-in PSoC Creator Code Examples with the Kit

Follow these steps to open and use the built-in PSoC Creator examples.

1. Launch PSoC Creator from **Start > All Programs > Cypress > PSoC Creator<version> > PSoC Creator <version>**.

2. On the Start Page, click **Find Code Example...** under **Examples and Kits**, or use the menu item **“File > Code Example...”** as shown in **Figure 4-7**.

**Figure 4-7. PSoC Creator Find Example Project...**
3. In the Find Code Example window, set the **Device Family** to **PSoC 4200DS** as shown in **Figure 4-8**.

![Figure 4-8. Selecting PSoC 4200DS Device Family in Find Code Example Window](image)

4. You can use any project that appears in the list with the kit. As an example, we will select the **CE97634 PSoC 4 Breathing LED** project and see how to use it with the CY8CKIT-146 kit.
5. Select the **CE97634 PSoC 4 Breathing LED** project and click the **Create Project** button as shown in Figure 4-9 button. Save the workspace to a desired location.

Figure 4-9. CE97634 PSoC 4 Breathing LED Code Example

6. Open **CE97634 PSoC 4 Breathing LED.pdf** from the Workspace Explorer to learn more about the example project and its configuration. See Figure 4-10.

Figure 4-10. Project Document: CE97634 PSoC 4 Breathing LED
A. Appendix

A.1 Board Details

The PSoC 4200DS Prototyping kit consists of the following blocks:

- PSoC 4200DS device (CY8C4246PVI-DS402)
- PSoC 4200DS I/O headers J1 and J2
- 10-pin PSoC 4200DS Program/Debug header, J9 (foot-print only)
- KitProg2 (PSoC 5LP) device (CY8C5868LTI-LP039)
- KitProg2 I/O headers J6 and J7
- SWD connection headers J4 and J5
- PCB USB finger connector J8
- One amber LED LED2 (Power)
- One amber LED LED3 (KitProg2 Status)
- One blue LED LED1 (User)
- One Push Button SW1 (User)
- One Reset Push Button SW2
- One KitProg2 Mode button SW3
- Current Measurement Jumper J3 (foot-print only) (shorted by zero ohm resistor R9)
- Perforated ‘snappable’ board design

Figure A-1. PSoC 4200DS Prototyping kit Pin Details
A.2 Hardware Details

A.2.1 Target Board

The target board uses the PSoC 4200DS device. PSoC 4200DS is a scalable and reconfigurable platform architecture for a family of programmable embedded system controllers with an ARM Cortex-M0 CPU. It combines programmable and reconfigurable digital blocks with flexible automatic routing. The PSoC 4200DS device family, based on this platform architecture, is a combination of a microcontroller with digital programmable logic, programmable interconnect, and standard communication and timing peripherals. The PSoC 4200DS products will be fully compatible with members of the PSoC 4 platform for new applications and design needs. The digital subsystems allow flexibility and in-field tuning of the design. For more information, refer to the PSoC 4200DS web page and the PSoC 4200DS Family Datasheet.

Figure A-2. Schematic of PSoC 4 (Target)
A.2.2 KitProg2 Board

A PSoC 5LP on the KitProg2 board is used to program and debug the target PSoC 4200DS device. The KitProg2 PSoC 5LP connects to the USB port of the PC through the PCB USB connector and to the SWD interface of the target PSoC 4200DS device.

Figure A-3. Schematic of PSoC 5LP (KitProg2)
A.2.3 Power Supply System

The power supply system on this board is dependent on the source of the power. For most applications, you can use the 5 V supply from the USB connection to power the system. You can also connect an external power supply to the board for low-voltage applications. The kit supports the following connections:
- 5 V from the KitProg2 USB (J8)
- 3.3 V to 5.5 V from a regulated supply connected to VTARG or VDDD

**Note:** In order to use an external power supply with the KitProg2 also connected to the PC USB, first remove diode D1 from the board. This ensures that the VTARG supply from KitProg2 is not supplied to the target device. KitProg2 measures the target voltage and adjusts the logic levels on the programming pins accordingly.

It is important to understand that this prototyping kit does not have any onboard ESD protection circuitry. Therefore, the power source for the PSoC 4200DS Prototyping kit must be of a high quality to ensure that the board is protected from any over-current conditions and swapped-power connections.

A.2.3.1 Measure PSoC 4200DS Current Consumption

You can measure current consumption of the PSoC 4200DS device by following the steps below.

1. Remove the resistors R9, R3 and install a 2-pin jumper in the supplied holes of J3.
2. Connect an ammeter across the 2-pin jumper to measure the current to the PSoC 4200DS device.

This method can be used either with USB power or with the power supplied to one of the VTARG pins but NOT when supplying power to one of the VDD pins.

After measuring the current consumption, populate the resistors R9, and R3 for normal operation of the kit.

A.2.4 Board Separation (Snapping)

The PSoC 4200DS Prototyping kit consists of a PSoC 4200DS and a KitProg2 board. To separate the two boards for evaluation or development, break the two boards apart at the built-in perforated edge between J4 and J5.

The easiest method of separating the two boards is to place the kit on the edge of a table, where the edge of the table is directly below the perforated edge and the smaller KitProg2 board is off the table edge. Press gently on the KitProg2 board and snap the two boards apart. If any material is removed from the edge of the boards, use sheers to clean up the edge of the kit.

Note that once the boards are separated, direct UART and I2C connections between the PSoC 4200DS device and KitProg2 are lost. This is because the traces connecting the UART and I2C lines are cut off during the separation. However, you can access KitProg2’s UART and I2C lines through header J6.

Figure A-4. PSoC 4200DS Prototyping kit Broken into Two Parts
A.2.5 Header Connections

The PSoC 4200DS Prototyping kit supports a number of unpopulated headers on both the KitProg2 and the target PSoC 4200DS boards.

A.2.5.1 Functionality of the J1 and J2 Headers (Target Board)

The target PSoC 4200DS board contains two single-inline headers (J1 and J2). These headers are both 1×14-pin headers and include all of the I/Os available on the PSoC 4200DS device. These headers support all of the available ports, GND, VTARG, and connections to passive elements and user-input devices.

The J1 and J2 headers support 100-mil spacing, so you can solder connectors to connect the target board to any development breadboard.

Figure A-5. J1 and J2 Headers

<table>
<thead>
<tr>
<th>Pin</th>
<th>Signal</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>J1_01</td>
<td>P2[7]</td>
<td>GPIO</td>
</tr>
<tr>
<td>J1_02</td>
<td>P2[6]</td>
<td>GPIO</td>
</tr>
<tr>
<td>J1_03</td>
<td>P2[5]</td>
<td>GPIO</td>
</tr>
<tr>
<td>J1_04</td>
<td>P2[4]</td>
<td>GPIO</td>
</tr>
<tr>
<td>J1_05</td>
<td>P2[3]</td>
<td>GPIO</td>
</tr>
<tr>
<td>J1_06</td>
<td>P2[2]</td>
<td>GPIO</td>
</tr>
<tr>
<td>J1_07</td>
<td>P0[0]</td>
<td>GPIO</td>
</tr>
<tr>
<td>J1_08</td>
<td>P0[1]</td>
<td>GPIO/User LED</td>
</tr>
<tr>
<td>J1_09</td>
<td>P0[2]</td>
<td>GPIO</td>
</tr>
<tr>
<td>J1_10</td>
<td>P0[4]</td>
<td>GPIO</td>
</tr>
<tr>
<td>J1_11</td>
<td>P0[5]</td>
<td>GPIO</td>
</tr>
<tr>
<td>J1_12</td>
<td>P0[6]</td>
<td>GPIO</td>
</tr>
<tr>
<td>J1_13</td>
<td>GND</td>
<td>Ground</td>
</tr>
<tr>
<td>J1_14</td>
<td>VTARG</td>
<td>Power</td>
</tr>
</tbody>
</table>

Table A-1. J1 Header Pin Details

<table>
<thead>
<tr>
<th>Pin</th>
<th>Signal</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>J2_01</td>
<td>VTARG</td>
<td>Power</td>
</tr>
<tr>
<td>J2_02</td>
<td>GND</td>
<td>Ground</td>
</tr>
<tr>
<td>J2_03</td>
<td>RST</td>
<td>Reset</td>
</tr>
<tr>
<td>J2_04</td>
<td>P3[3]/SWD CLK</td>
<td>GPIO/SWD Clock</td>
</tr>
<tr>
<td>J2_05</td>
<td>P3[2]/SWDIO</td>
<td>GPIO/SWD Data</td>
</tr>
<tr>
<td>J2_06</td>
<td>P3[4]</td>
<td>GPIO</td>
</tr>
<tr>
<td>J2_07</td>
<td>P3[1]/SDA</td>
<td>GPIO/I2C Data</td>
</tr>
<tr>
<td>J2_08</td>
<td>P3[0]/SCL</td>
<td>GPIO/I2C Clock</td>
</tr>
<tr>
<td>J2_09</td>
<td>P1[3]</td>
<td>GPIO/User Switch</td>
</tr>
<tr>
<td>J2_10</td>
<td>P1[2]</td>
<td>GPIO</td>
</tr>
<tr>
<td>J2_11</td>
<td>P1[1]/TX</td>
<td>GPIO/UART TX</td>
</tr>
<tr>
<td>J2_12</td>
<td>P1[0]/RX</td>
<td>GPIO/UART RX</td>
</tr>
<tr>
<td>J2_13</td>
<td>GND</td>
<td>Ground</td>
</tr>
<tr>
<td>J2_14</td>
<td>VTARG</td>
<td>Power</td>
</tr>
</tbody>
</table>

Table A-2. J2 Header Pin Details
A.2.5.2  Functionality of J4 and J5 Headers (PSOC 5LP to KitProg2)

The KitProg2 and target boards each contain a 1x5-pin header. These headers provide a physical connection between the two devices. Specifically, the connection includes the SWD interface, required to program/debug the target PSoC 5LP device, power, ground, and reset.

Figure A-6. J4 and J5 Headers

<table>
<thead>
<tr>
<th>Pin</th>
<th>Signal</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>J4_01</td>
<td>VTARG</td>
<td>Power</td>
</tr>
<tr>
<td>J4_02</td>
<td>GND</td>
<td>Ground</td>
</tr>
<tr>
<td>J4_03</td>
<td>P12.4</td>
<td>Target Reset/GPIO</td>
</tr>
<tr>
<td>J4_04</td>
<td>P12.3</td>
<td>Target SWD_CLK/GPIO</td>
</tr>
<tr>
<td>J4_05</td>
<td>P12.2</td>
<td>Target SWD_IO/GPIO</td>
</tr>
</tbody>
</table>

Table A-3. Pin Details of J4 Header

<table>
<thead>
<tr>
<th>Pin</th>
<th>Signal</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>J5_01</td>
<td>VTARG</td>
<td>Power</td>
</tr>
<tr>
<td>J5_02</td>
<td>GND</td>
<td>Ground</td>
</tr>
<tr>
<td>J5_03</td>
<td>XRES</td>
<td>Target Reset</td>
</tr>
<tr>
<td>J5_04</td>
<td>P3.3</td>
<td>Target SWD_CLK/GPIO</td>
</tr>
<tr>
<td>J5_05</td>
<td>P3.2</td>
<td>Target SWD_IO/GPIO</td>
</tr>
</tbody>
</table>

Table A-4. Pin Details of J5 Header

When the boards are separated, the KitProg2 board can be used to program any other PSoC 3, PSoC 4, PSoC 5LP family of devices via J4.
A.2.5.3 Functionality of J6 and J7 Headers (KitProg2)

The KitProg2 board contains two single-inline headers (J6 and J7). Both are 1x7-pin-headers, used to pull out several pins of the PSoC 5LP to support advanced features like a low-speed oscilloscope and a low-speed digital logic analyzer. This header also contains the KitProg2 bridge pins that can be used when the two boards are separated.

The J6 and J7 headers support 100-mil spacing, so you can solder connectors to connect the KitProg2 board to any development breadboard.

Figure A-7: J6 and J7 Headers

<table>
<thead>
<tr>
<th>PSoC 5LP KitProg2 Header (J6)</th>
<th>PSoC 4200DS Prototyping kit GPIO Header</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pin</td>
<td>Signal</td>
</tr>
<tr>
<td>J6_01</td>
<td>VBUS</td>
</tr>
<tr>
<td>J6_02</td>
<td>GND</td>
</tr>
<tr>
<td>J6_03</td>
<td>P12.5</td>
</tr>
<tr>
<td>J6_04</td>
<td>P12.0</td>
</tr>
<tr>
<td>J6_05</td>
<td>P12.1</td>
</tr>
<tr>
<td>J6_06</td>
<td>P12.7</td>
</tr>
<tr>
<td>J6_07</td>
<td>P12.6</td>
</tr>
</tbody>
</table>
A.2.5.4 Functionality of Connector J8 (USB Connector)

This USB finger connector footprint on the kit enables user to connect the kit directly to USB port of the PC.

Figure A-8. USB Type-A connector J8

A.2.6 User and Passive Inputs

A.2.6.1 User Switch

The target PSoC 4200DS board contains a single push button connected to the P1[3] pin on the PSoC 4200DS device. This button can be used for general user inputs or to control different states in an application.

Figure A-9. User Button on the Board
A.2.6.2 **Reset Switch**

Reset the target PSoC device: When this button is pressed, XRES line of the PSoC 4200DS is connected to ground, which, in turn, resets the target device.

Figure A-10. Reset (RST) Button

A.2.6.3 **Mode Switch**

The KitProg2 board contains a push button connected to P1.2 of the PSoC 5LP. This can be used to switch between different modes of KitProg2 such as Programmer/Debugger, Mass storage programmer, Bootloader and custom application. Refer to the KitProg2 User Guide for more details. This button can also be used as general purpose button in custom application for PSoC 5LP device.

Figure A-11. Mode Switch

A.2.6.4 **LEDs**

The PSoC 4200DS Prototyping kit contains three LEDs:

- The amber Power LED (LED2): Indicates that the board is powered from the PCB USB connector. This LED will not glow when the board is powered from VDD or VTARG directly.
- The amber Status LED (LED3): Indicates the KitProg2 status, connected to P1[4] of the KitProg2 PSoC 5LP device. Refer to Table 3-1 on page 19 for more details on LED behavior.
- The blue LED (LED1): This is the user LED, connected to P0[1] of the target PSoC 4200DS device.

Figure A-12. Power LED
Figure A-13. Status LED

Figure A-14. User LED
A.2.6.5 10-pin Programming Header

PSoC 4200DS can be programmed alternatively through the 10-pin programming header using a Miniprog3 programmer. This can be done by connecting the 10-pin programming header from a Miniprog3 to the 10-pin programming header J9 on the CY8CKIT-146.

Figure A-15. 10-pin Programming Header

A.3 PSoC 4200DS Prototyping kit Schematics

Refer to the schematic files in the following paths in the installed kit software:

<Install_Directory>\CY8CKIT-146 PSoC 4200DS Prototyping Kit\<version>\Hardware\CY8CKIT-146 Schematic.pdf

A.4 Bill of Materials

Refer to the BOM files in the following paths in the kit software installed:

<Install_Directory>\CY8CKIT-146 PSoC 4200DS Prototyping Kit\<version>\Hardware\CY8CKIT-146 PCBA_BOM.xlsm
A.5 Programming PSoC 4200DS Prototyping kit Using MiniProg3/KitProg2

The target board provides a provision to program the PSoC 4200DS device using MiniProg3 or an external KitProg2 via the 10-pin JTAG header or the 5-pin SWD header. To do this, connect wires or a 5-pin 100-mil spaced header to J5 or a 10-pin JTAG header to J9 on the target board. The PSoC 4200DS Prototyping kit supports both power cycle and reset programming modes.

Figure A-16. Connecting the CY8CKIT-146 to a MiniProg3

Note: CY8CKIT-002 MiniProg3 is not part of the PSoC 4200DS Prototyping Kit contents and can be purchased from the Cypress Online Store.
# Revision History

<table>
<thead>
<tr>
<th>Revision</th>
<th>ECN#</th>
<th>Issue Date</th>
<th>Origin of Change</th>
<th>Description of Change</th>
</tr>
</thead>
<tbody>
<tr>
<td>**</td>
<td>5629660</td>
<td>02/15/2017</td>
<td>NMIT</td>
<td>New kit guide.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Updated Introduction chapter on page 7:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Updated “Kit Contents” on page 7:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Updated Figure 1-1.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Updated “PSoC Creator” on page 8:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Updated “PSoC Creator Code Examples” on page 9:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Updated Figure 1-3.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Updated Figure 1-4.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Updated “Kit Code Examples” on page 10:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Updated description.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Updated Software Installation chapter on page 15:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Updated “Install Software” on page 15:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Updated Figure 2-1.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Updated Kit Operation chapter on page 18:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Updated “Theory of Operation” on page 18:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Updated Figure 3-1.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Updated description.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Updated Code Examples chapter on page 24:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Updated “Using the Kit Code Examples” on page 24:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Updated Figure 4-1.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Updated Figure 4-4.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Updated Figure 4-6 (Updated caption only).</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Updated “Using Built-in PSoC Creator Code Examples with the Kit” on page 28:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Updated Figure 4-9.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Updated Figure 4-10 (Updated caption only).</td>
</tr>
</tbody>
</table>
# Document Revision History (continued)

<table>
<thead>
<tr>
<th>Revision</th>
<th>ECN#</th>
<th>Issue Date</th>
<th>Origin of Change</th>
<th>Description of Change</th>
</tr>
</thead>
</table>
## Document Revision History (continued)

<table>
<thead>
<tr>
<th>Revision</th>
<th>ECN#</th>
<th>Issue Date</th>
<th>Origin of Change</th>
<th>Description of Change</th>
</tr>
</thead>
</table>
| *B (cont.) | 5674892 | 03/28/2017 | VRBS             | Updated Appendix chapter on page 31:  
Updated “Hardware Details” on page 32:  
Updated “Header Connections” on page 35:  
Updated “Functionality of J4 and J5 Headers (PSoC 5LP to KitProg2)” on page 36:  
Updated Table A-3.  
Updated Table A-4.  
Updated “User and Passive Inputs” on page 38:  
Updated “Mode Switch” on page 39:  
Updated description.  
Updated Figure A-11 (Updated caption only).  
Updated “LEDs” on page 39:  
Updated description. |