1. Relevant Devices

The C8051F360 Development Kit is intended as a development platform for the microcontrollers in the C8051F36x MCU family.

Notes:
- The target board included in this kit is provided with a pre-soldered C8051F360 MCU (LQFP48 package).
- Code developed on the C8051F360 can be easily ported to the other members of this MCU family.
- Refer to the C8051F36x data sheet for the differences between the members of this MCU family.
- The C8051F36x family of devices are code-compatible with the C8051F330/1/2/3/4/5 family of devices.

2. Kit Contents

The C8051F36x-DK Development Kit contains the following items:
- C8051F360 Target Board
- C8051Fx X Development Kit Quick-Start Guide
- AC/DC Power Adapter
- USB Debug Adapter (USB to Debug Interface)
- USB Cable
- CD-ROM

3. Hardware Setup Using a USB Debug Adapter

The target board is connected to a PC running the Simplicity Studio via the USB Debug Adapter as shown in Figure 1.

1. Connect the USB Debug Adapter to the DEBUG connector on the target board with the 10-pin ribbon cable.
2. Connect one end of the USB cable to the USB connector on the USB Debug Adapter.
3. Connect the other end of the USB cable to a USB Port on the PC.
4. Connect the AC/DC Power Adapter to power jack P2 on the target board.

Notes:
- Use the Reset button in the IDE to reset the target when connected using a USB Debug Adapter.
- Remove power from the target board before removing the ribbon cable from the target board. Connecting or disconnecting the cable when the devices have power can damage the device and/or the USB Debug Adapter.
Figure 1. Hardware Setup using a USB Debug Adapter
4. Software Setup

Simplicity Studio greatly reduces development time and complexity with Silicon Labs EFM32 and 8051 MCU products by providing a high-powered IDE, tools for hardware configuration, and links to helpful resources, all in one place.

Once Simplicity Studio is installed, the application itself can be used to install additional software and documentation components to aid in the development and evaluation process.

The following Simplicity Studio components are required for the C8051F360 Development Kit:

- 8051 Products Part Support
- Simplicity Developer Platform

Download and install Simplicity Studio from www.silabs.com/8bit-software or www.silabs.com/simplicity-studio. Once installed, run Simplicity Studio by selecting Start → Silicon Labs → Simplicity Studio → Simplicity Studio from the start menu or clicking the Simplicity Studio shortcut on the desktop. Follow the instructions to install the software and click Simplicity IDE to launch the IDE.

The first time the project creation wizard runs, the Setup Environment wizard will guide the user through the process of configuring the build tools and SDK selection.

In the Part Selection step of the wizard, select from the list of installed parts only the parts to use during development. Choosing parts and families in this step affects the displayed or filtered parts in the later device selection menus. Choose the C8051F36x family by checking the C8051F36x check box. Modify the part selection at any time by accessing the Part Management dialog from the Window → Preferences → Simplicity Studio → Part Management menu item.

Simplicity Studio can detect if certain toolchains are not activated. If the Licensing Helper is displayed after completing the Setup Environment wizard, follow the instructions to activate the toolchain.
4.1. Running Blinky

Each project has its own source files, target configuration, SDK configuration, and build configurations such as the Debug and Release build configurations. The IDE can be used to manage multiple projects in a collection called a workspace. Workspace settings are applied globally to all projects within the workspace. This can include settings such as key bindings, window preferences, and code style and formatting options. Project actions, such as build and debug are context sensitive. For example, the user must select a project in the Project Explorer view in order to build that project.

To create a project based on the Blinky example:

1. Click the Software Examples tile from the Simplicity Studio home screen.
2. In the Kit drop-down, select C8051F360 Development Kit, in the Part drop-down, select C8051F360, and in the SDK drop-down, select the desired SDK. Click Next.
3. Under C8051F360 Development Kit, select F36x Blinky, click Next, and click Finish.
4. Click on the project in the Project Explorer and click Build, the hammer icon in the top bar. Alternatively, go to Project→Build Project.
5. Click Debug to download the project to the hardware and start a debug session.
6. Press the Resume button to start the code running. The LED should blink.
7. Press the Suspend button to stop the code.
8. Press the Reset the device button to reset the target MCU.
9. Press the Disconnect button to return to the development perspective.

4.2. Simplicity Studio Help

Simplicity Studio includes detailed help information and device documentation within the tool. The help contains descriptions for each dialog window. To view the documentation for a dialog, click the question mark icon in the window:

This will open a pane specific to the dialog with additional details.

The documentation within the tool can also be viewed by going to Help→Help Contents or Help→Search.
4.3. CP210x USB to UART VCP Driver Installation

The Target Board includes a Silicon Labs CP210x USB-to-UART Bridge Controller. Device drivers for the CP210x need to be installed before the PC software can communicate with the MCU through the UART interface. Use the drivers included CD-ROM or download the latest drivers from the website (www.silabs.com/interface-software).

1. If using the CD-ROM, the CP210x Drivers option will launch the appropriate driver installer. If downloading the driver package from the website, unzip the files to a location and run the appropriate installer for the system (x86 or x64).

2. Accept the license agreement and follow the steps to install the driver on the system. The installer will let you know when your system is up to date. The driver files included in this installation have been certified by Microsoft.

3. To complete the installation process, connect the included USB cable between the host computer and the USB connector (P4) on the Target Board. Windows will automatically finish the driver installation. Information windows will pop up from the taskbar to show the installation progress.

4. If needed, the driver files can be uninstalled by selecting Windows Driver Package—Silicon Laboratories... option in the Programs and Features window.
5. Target Board

The C8051F36x Development Kit includes a target board with a C8051F360 device pre-installed for evaluation and preliminary software development. Numerous input/output (I/O) connections are provided to facilitate prototyping using the target board. Refer to Figure 3 for the locations of the various I/O connectors.

- **P1**: 96-pin female connector
- **P2**: Power connector (Accepts input from 7 to 15 VDC unregulated power adapter.)
- **P3**: Analog I/O terminal block
- **P4**: USB connector (for CP2102 USB-to-UART bridge)
- **J1**: Power supply header (Selects power from the USB Debug Adapter, P1 Power Adapter, or USB power if P4 is connected. Only one power option should be selected at one time.)
- **J2**: Port 0 header
- **J3**: Port 1 header
- **J4**: Port 2 header
- **J5**: Port 3 header
- **J6**: Port 4 header
- **J7**: Connects the +3 V supply net to the VDD supply net
- **J8**: Supply signal header
- **J9**: Debug connector for debug adapter interface
- **J10, J11**: External crystal port pin enable connectors
- **J12**: Port I/O jumper configuration block
- **J13**: Jumper connection for potentiometer to pin 2.5
- **J14**: Jumper connection for potentiometer source to +3 V
- **J15**: Jumper connection for pin 0.3 to capacitors (used when VREF is internally generated)
- **J16**: Jumper connection for pin 0.4 to resistor/capacitor (used to convert IDAC output to a voltage)
- **J18**: Connects the +3 V supply net to the AV+ supply net

![Figure 3. C8051F360 Target Board](SA-TB52PCB)
5.1. System Clock Sources

The C8051F360 device installed on the target board features a calibrated programmable internal oscillator which is enabled as the system clock source on reset. After reset, the internal oscillator operates at a frequency of 3.0625 MHz (±1.5%) by default but may be configured by software to operate at other frequencies. Therefore, in many applications an external oscillator is not required. However, if you wish to operate the C8051F360 device at a frequency not available with the internal oscillator, an external crystal may be used. Refer to the C8051F36x data sheet for more information on configuring the system clock source.

The target board is designed to facilitate the installation of an external crystal. Remove shorting blocks at headers J10 and J11 and install the crystal at the pads marked Y1. Install a 10 MΩ resistor at R1 and install capacitors at C20 and C19 using values appropriate for the crystal you select. Refer to the C8051F36x data sheet for more information on the use of external oscillators.

5.2. Switches and LEDs

Three switches are provided on the target board. Switch RESET is connected to the RESET pin of the C8051F360. Pressing RESET puts the device into its hardware-reset state. Switches P3.0 and P3.1 are connected to the C8051F360’s general purpose I/O (GPIO) pins through headers. Pressing P3.0 or P3.1 generates a logic low signal on the port pin. Remove the shorting blocks from the J12 header to disconnect Switch P3.0 and Switch P3.1 from the port pins. See Table 1 for the port pins and headers corresponding to each switch.

Four LEDs are also provided on the target board. The red LED labeled PWR is used to indicate a power connection to the target board. The green surface-mount LEDs labeled with port pin names are connected to the C8051F360’s GPIO pins through headers. Remove the shorting blocks from the header to disconnect the LEDs from the port pin. The USB ACTIVE red LED indicates when the CP210x USB-to-UART bridge (U3) on the board is receiving power from the USB bus and is properly enumerated (i.e. drivers are installed and a USB cable is connected to P4). See Table 1 for the port pins and headers corresponding to each LED.

Also included on the C8051F360 target board is a 10 KΩ thumb-wheel rotary potentiometer, part number R10. The potentiometer is connected to the C8051F360’s P2.5 pin through the J13 header. Remove the shorting block from the header to disconnect the potentiometer from the port pin. See Table 1 for the port pin and header corresponding to the potentiometer.

Table 1. Target Board I/O Descriptions

<table>
<thead>
<tr>
<th>Description</th>
<th>I/O</th>
<th>Header</th>
</tr>
</thead>
<tbody>
<tr>
<td>SW1</td>
<td>Reset</td>
<td>none</td>
</tr>
<tr>
<td>SW2</td>
<td>P3.0</td>
<td>J12[1–2]</td>
</tr>
<tr>
<td>SW3</td>
<td>P3.1</td>
<td>J12[3–4]</td>
</tr>
<tr>
<td>Green LED</td>
<td>P3.2</td>
<td>J12[5–6]</td>
</tr>
<tr>
<td>Green LED</td>
<td>P3.3</td>
<td>J12[7–8]</td>
</tr>
<tr>
<td>Red LED</td>
<td>PWR</td>
<td>none</td>
</tr>
<tr>
<td>Red LED</td>
<td>USB ACTIVE</td>
<td>none</td>
</tr>
<tr>
<td>Potentiometer</td>
<td>P2.5</td>
<td>J13</td>
</tr>
</tbody>
</table>
5.3. PORT I/O Connectors (J2 - J6)
In addition to all port I/O signals being routed to the 96-pin expansion connector, each of the five parallel ports of the C8051F360 has its own 10-pin header connector. Each connector provides a pin for the corresponding port pins 0–7, +3.3 VDC and digital ground. Table 3 defines the pins for the port connectors, where Pn represents P0 through P4. The same pin-out order is used for all of the port connectors.

Table 2. J12–J19 Port Connector Pin Descriptions

<table>
<thead>
<tr>
<th>Pin #</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Pn.0</td>
</tr>
<tr>
<td>2</td>
<td>Pn.1</td>
</tr>
<tr>
<td>3</td>
<td>Pn.2</td>
</tr>
<tr>
<td>4</td>
<td>Pn.3</td>
</tr>
<tr>
<td>5</td>
<td>Pn.4</td>
</tr>
<tr>
<td>6</td>
<td>Pn.5</td>
</tr>
<tr>
<td>7</td>
<td>Pn.6</td>
</tr>
<tr>
<td>8</td>
<td>Pn.7 (not connected for J6)</td>
</tr>
<tr>
<td>9</td>
<td>+3 VD (+3.3 VDC)</td>
</tr>
<tr>
<td>10</td>
<td>GND (Ground)</td>
</tr>
</tbody>
</table>

5.4. Target Board DEBUG Interface (J9)
The DEBUG connector (J9) provides access to the DEBUG (C2) pins of the C8051F360. It is used to connect the Serial Adapter or the USB Debug Adapter to the target board for in-circuit debugging and Flash programming. Table 3 shows the DEBUG pin definitions.

Table 3. DEBUG Connector Pin Descriptions

<table>
<thead>
<tr>
<th>Pin #</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>+3 VD (+3.3 VDC)</td>
</tr>
<tr>
<td>2, 3, 9</td>
<td>GND (Ground)</td>
</tr>
<tr>
<td>4</td>
<td>C2D</td>
</tr>
<tr>
<td>5</td>
<td>/RST (Reset)</td>
</tr>
<tr>
<td>6</td>
<td>P4.6</td>
</tr>
<tr>
<td>7</td>
<td>C2CK</td>
</tr>
<tr>
<td>8</td>
<td>Not Connected</td>
</tr>
<tr>
<td>10</td>
<td>USB Power (from USB Debug Adapter)</td>
</tr>
</tbody>
</table>
5.5. USB to Serial Connector (P1)
A USB-to-Serial bridge interface is provided. A USB B-type connector (P1), a Silicon Laboratories CP2102 USB-to-UART Bridge, and related circuits are provided to facilitate the serial connection between a PC and the C8051F360 microcontroller on the target board. The RX, TX, CTS and RTS signals of the UART side of the Bridge (CP2102) may be connected to the microcontroller by installing shorting blocks on J12 as follows:

Table 4. UART Connections (J12)

<table>
<thead>
<tr>
<th>Connection</th>
<th>Signals</th>
</tr>
</thead>
<tbody>
<tr>
<td>J12[9–10]</td>
<td>P0.1 to TX_MC</td>
</tr>
<tr>
<td>J12[11–12]</td>
<td>P0.2 to RX_MC</td>
</tr>
<tr>
<td>J12[13–14]</td>
<td>P3.4 to RTS</td>
</tr>
<tr>
<td>J12[15–16]</td>
<td>P3.5 to CTS</td>
</tr>
</tbody>
</table>

5.6. Analog I/O (P2)
Several of the C8051F360 target device’s port pins are connected to the P3 terminal block. Refer to Table 5 for the P3 terminal block connections.

Table 5. J6 Terminal Block Pin Descriptions

<table>
<thead>
<tr>
<th>Pin #</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>P2.3/AIN2.3/CP0+</td>
</tr>
<tr>
<td>2</td>
<td>P2.4/AIN2.4/CP0–</td>
</tr>
<tr>
<td>3</td>
<td>GND (Ground)</td>
</tr>
<tr>
<td>4</td>
<td>P0.3/VREF (Voltage Reference)</td>
</tr>
<tr>
<td>5</td>
<td>P0.4/IDAC</td>
</tr>
</tbody>
</table>

5.7. Power Connector (J1)
The Target Board can be powered from three different sources: 1) The regulator input from the P2 9 V DC Power Adapter, 2) The 5 V VBUS signal if P4 is connected to a USB bus, and 3) The 5 V USB bus if a USB Debug Adapter is connected to the Debug Header (J9). Place a shorting block at header J1[REG_IN-P1_PWR] to power the board directly from an AC/DC Power Adapter. Place a shorting block at header J1[REG_IN-VBUS] to power the board from the USB bus connected to P4. Place a shorting block at header J1[REG_IN-SER_PWR] to power the board from the USB Debug Adapter. Please note that the second option is not supported if a USB bus is not connected to P4 and the third option is not supported with either the EC1 or EC2 Serial Adapters.

Note: Only one power option should be selected at one time.
6. Schematics
DOCUMENT CHANGE LIST

Revision 0.1 to Revision 0.2

- Added Relevant Devices section.
- Section 2 moved to Section 5.
- Change section 3 to "Getting Started."
- Updated section 3 to include latest VCP driver installation instructions.
- Changed section 4 to "Software Overview."
- Updated Evaluation Compiler restrictions in section 4.2.2.
- Added overview of Configuration Wizard 2 and Keil uVision Drivers to section 4.
- Created new section 6.

Revision 0.2 to Revision 0.3

- Updated "Software Setup," on page 3.
Disclaimer
Silicon Laboratories intends to provide customers with the latest, accurate, and in-depth documentation of all peripherals and modules available for system and software implementers using or intending to use the Silicon Laboratories products. Characterization data, available modules and peripherals, memory sizes and memory addresses refer to each specific device, and "Typical" parameters provided can and do vary in different applications. Application examples described herein are for illustrative purposes only. Silicon Laboratories reserves the right to make changes without further notice and limitation to product information, specifications, and descriptions herein, and does not give warranties as to the accuracy or completeness of the included information. Silicon Laboratories shall have no liability for the consequences of use of the information supplied herein. This document does not imply or express copyright licenses granted hereunder to design or fabricate any integrated circuits. The products must not be used within any Life Support System without the specific written consent of Silicon Laboratories. A "Life Support System" is any product or system intended to support or sustain life and/or health, which, if it fails, can be reasonably expected to result in significant personal injury or death. Silicon Laboratories products are generally not intended for military applications. Silicon Laboratories products shall under no circumstances be used in weapons of mass destruction including (but not limited to) nuclear, biological or chemical weapons, or missiles capable of delivering such weapons.

Trademark Information
Silicon Laboratories Inc., Silicon Laboratories, Silicon Labs, SiLabs and the Silicon Labs logo, CMEMS®, EFM, EFM32, EFR, Energy Micro, Energy Micro logo and combinations thereof, "the world's most energy friendly microcontrollers", Ember®, EZLink®, EZMac®, EZRadio®, EZRadioPRO®, DSPLL®, ISOmodem®, Precision32®, ProSLIC®, SiPHY®, USBXpress® and others are trademarks or registered trademarks of Silicon Laboratories Inc. ARM, CORTEX, Cortex-M3 and THUMB are trademarks or registered trademarks of ARM Holdings. Keil is a registered trademark of ARM Limited. All other products or brand names mentioned herein are trademarks of their respective holders.